数字统计

1.5k 词

题目描述

一本书的页码从自然数1 开始顺序编码直到自然数n。书的页码按照通常的习惯编排,每个页码都不含多余的前导数字0。例如,第6 页用数字6 表示,而不是06 或006 等。数字计数问题要求对给定书的总页码n,计算出书的全部页码中分别用到多少次数字0,1,2,…,9。

输入

给出表示书的总页码的整数n($1≤n≤2^{31}-1$)

输出

输出10行,在第k行输出页码中用到数字k-1 的次数,k=1,2,…,10。

样例输入

1
11

样例输出

1
2
3
4
5
6
7
8
9
10
1
4
1
1
1
1
1
1
1
1

题解

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
import java.util.Scanner;

public class Main {
public static int[] num = new int[10];

public static void main(String[] args) {
Scanner cin = new Scanner(System.in);
int n = 0;
n = cin.nextInt();
Count(n);
num[0] -= del_zero(get_length(n));
for (int i = 0; i < 10; i++)
System.out.println(num[i]);
}

public static int get_length(int num) {
return (int) Math.log10(num) + 1;
}

public static int get_head(int num) {
return num / (int) Math.pow(10, get_length(num) - 1);
}

public static int get_remainder(int num) {
return num % (int) Math.pow(10, get_length(num) - 1);
}

public static int del_zero(int length) {
if (length == 1)
return 1;
return del_zero(length - 1) + (int) Math.pow(10, length - 1);
}

public static void Count(int n) {

for (int i = 0; i < 10; i++) {
num[i] = num[i] + get_head(n) * (get_length(n) - 1) * (int) Math.pow(10, (get_length(n) - 2));
}

for (int i = 0; i < get_head(n); i++) {
num[i] = num[i] + (int) Math.pow(10, get_length(n) - 1);
}

num[get_head(n)] += get_remainder(n) + 1;

if (get_remainder(n) == 0) {
num[0] += get_length(n) - 1;
return;
}

if (get_length(n) - 1 != get_length(get_remainder(n))) {
num[0] += (get_length(n) - 1 - get_length(get_remainder(n))) * (get_remainder(n) + 1);
}
Count(get_remainder(n));
}
}