懒省事的小明

1.8k 词

题目描述

小明很想吃果子,正好果园果子熟了。在果园里,小明已经将所有的果子打了下来,而且按果子的不同种类分成了不同的堆。小明决定把所有的果子合成一堆。 因为小明比较懒,为了省力气,小明开始想点子了:

每一次合并,小明可以把两堆果子合并到一起,消耗的体力等于两堆果子的重量之和。可以看出,所有的果子经过n-1次合并之后,就只剩下一堆了。小明在合并果子时总共消耗的体力等于每次合并所耗体力之和。
因为还要花大力气把这些果子搬回家,所以小明在合并果子时要尽可能地节省体力。假定每个果子重量都为$1$,并且已知果子的种类数和每种果子的数目$a_i$,你的任务是设计出合并的次序方案,使小明耗费的体力最少,并输出这个最小的体力耗费值。

输入

输入第一行是一个整数$n$ , $1 \le n \le 10^6$,表示果子的种类数。第二行包含$n$个整数,用空格分隔,第$i$个整数$a_i$ ,$1 \le a_i \le 2 \times 10^5$是第$i$种果子的数目。

输出

 输出每组测试数据输出包括一行,这一行只包含一个整数,也就是最小的体力耗费值。

样例输入

1
2
3
1 2 9

样例输出

1
15

提示

例如有3种果子,数目依次为$1,2,9$。可以先将$1、2$堆合并,新堆数目为$3$,耗费体力为$3$。接着,将新堆与原先的第三堆合并,又得到新的堆,数目为$12$,耗费体力为$12$。所以小明总共耗费$体力=3+12=15$。可以证明15为最小的体力耗费值。

题解

Java

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
import java.io.BufferedInputStream;
import java.io.BufferedOutputStream;
import java.io.PrintWriter;
import java.util.PriorityQueue;
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
int n = cin.nextInt();
PriorityQueue < Long > Q = new PriorityQueue < > ();
long tot = 0;
while(n-- > 0) {
Q.offer(cin.nextLong());
}
while(Q.size() > 1) {
long x = Q.peek();
Q.poll();
long y = Q.peek();
Q.poll();
tot += x + y;
Q.offer(x + y);
}
cout.println(tot);
cin.close();
cout.close();
}
static Scanner cin = new Scanner(new BufferedInputStream(System.in));
static PrintWriter cout = new PrintWriter(new BufferedOutputStream(System.out));
static PrintWriter cerr = new PrintWriter(System.err, true);
}

C++

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
#include <iostream>
#include <queue>
using namespace std;
int main(){
ios::sync_with_stdio(false);
cin.tie(nullptr);
int n,x,a,b;
cin>>n;
long long z=0;
priority_queue<int,vector<int>,greater<int> > q;
for(int i=0;i<n;++i){
cin>>x;
q.emplace(x);
}
while(q.size()!=1){
a=q.top();
q.pop();
b=q.top();
q.pop();
z+=a+b;
q.push(a+b);
}
cout<<z;
return 0;
}