括号匹配

1.1k 词

题目描述

在编程当中我们只会用到三种括号:圆括号(),方括号[]和花括号{},编译器在编译的时候会检查括号是否正确匹配。例如{[()]}、{()[]{}}都是合法的匹配。但是([)]则是不合法的匹配。请编写一个程序来判断输入的括号序列是否合法。

输入

测试数据由多组,每组数据有一行,为( ) [ ] { }组成的序列,长度不超过1000

输出

对于每组数据输出一行,如果是合法匹配则输出YES,不合法则输出NO,请注意大小写

样例输入

1
{([()]{})}

样例输出

1
YES

题解

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
#include <iostream>
#include <cstring>
using namespace std;
int main()
{
char s[1010],ch[1010];
label:
while (cin >> ch) {
int len = strlen(ch);
int top = 0;
for (int i = 0; i < len; i++)
{
if (ch[i] == '(' ch[i] == '[' ch[i] == '{') s[++top] = ch[i];
if (ch[i] == ')')
{
if (s[top] == '(')top--;
else
{
cout << "NO" << endl;
goto label;
}
}
if (ch[i] == ']')
{
if (s[top] == '[')top--;
else
{
cout << "NO" << endl;
goto label;
}
}
if (ch[i] == '}')
{
if (s[top] == '{')top--;
else
{
cout << "NO" << endl;
goto label;
}
}
}
if (top == 0)cout << "YES" << endl;
else cout << "NO" << endl;
}
return 0;
}