五个数AB*CDE乘积最大

354 词

题目描述

输入5个个位数 ABCDE(至少2个非0),要求按组合出一个三位数和2位数,使得乘积最大,你的任务是输出这个乘积最大

输入

输入5个个位数 ABCDE(至少2个非0)

输出

输出这个乘积最大

样例输入

1
0 1 2 3 4

样例输出

1
13120

题解

1
2
3
4
5
6
7
8
9
10
11
12
#include<iostream>
#include <algorithm>
using namespace std;
int main()
{
int n=5;
int a[n];
for(int i=0;i<n;i++)cin>>a[i];
sort(a,a+n);
cout<<(a[3]*100+a[2]*10+a[0])*(a[4]*10+a[1])<<endl;
return 0;
}